Aikido✓

@AikidoSecurity

Security for developers and everyone else 🌐 https://t.co/xLANl2VLwq ⭐️ https://t.co/qEhI9gQLeo ☀️ https://t.co/i0HAvBSw42

1.2K Following22.8K Followers3.1K Posts
  1. Aikido✓@AikidoSecurity
    Aikido
    RT @creatine_cycle: okay so i bought the harness. how do i connect this to my agents?
    Download
    01380168
  2. Aikido✓@AikidoSecurity
    Aikido
    RT @evnsio: An uplifting talk from @madelinelawren at SEV0. “At this point we need assume everything will be hacked” 🫠
    020215
  3. Aikido✓@AikidoSecurity
    Evolving threat 🚨 CVE-2026-111497, previously known to affect Node.js (node2shell) and Python has evolved into “HTTP2Shell.” A significant blast radius. This vulnerability leaves many libraries and applications using HTTP vulnerable to pre-auth RCE via Brotli decompression. Please be aware. Fixes not yet available for all affected services. Look for Brotli (1.2.1) dependency upgrades when they become available.
    Download
    1178503.5K805K
  4. Aikido✓@AikidoSecurity
    Posts @AikidoSecurity
    pilvar (Philippe Dourassov) @pilvar222
    We made a website to check if your http client is vulnerable to CVE-2026-111497 (Node2Shell/HTTP2Shell) Also open-source: Some examples:
    004248
  5. Aikido✓@AikidoSecurity
    Aikido
    RT @horia_nita: Is your HTTP client vulnerable to CVE-2026-111497 (Node2Shell/HTTP2Shell)? We built a website to help you check: The checker is open source:
    020236
  6. Aikido✓@AikidoSecurity
    Aikido
    RT @pilvar222: We made a website to check if your http client is vulnerable to CVE-2026-111497 (Node2Shell/HTTP2Shell) Also open-source: Some examples:
    0260243
  7. Aikido✓@AikidoSecurity
    So how to patch PHP2Shell with free Aikido Images? PHP shipped fixes on October 21 in 8.5.12, 8.4.27, 8.3.36 and 8.2.35. PHP 8.1 and older won't get an upstream release. Moving an application across PHP major versions takes time, and a legacy app on PHP 5.6 or 7.4 can't jump to 8.2 overnight. Aikido Images keep you on your current release line, so you can get back online faster. Here's the full guide so you can get secure for free : 🧵
    Download
    51133.1K
  8. Aikido✓@AikidoSecurity
    Posts @AikidoSecurity
    Aikido Images are free on the Aikido public ECR. Find your release line and pull the latest patch in the variant you use. ->
    Download
    203326
  9. Aikido✓@AikidoSecurity
    Posts @AikidoSecurity
    Patching a running container leaves the image exposed, so rebuild every image that uses PHP and redeploy. Then: 1. Restart PHP-FPM and Apache workers, and confirm no worker still runs the old build. 2. Keep session.upload_progress.enabled=0 in php.ini or your PHP-FPM pool configuration. 3. Test your public URL with Aikido's free PHP2Shell checker → 4. Look for signs of compromise →
    002220
  10. Aikido✓@AikidoSecurity
    Aikido
    RT @pilvar222: We ran MiniMax M3.1 Flash on our cybersecurity benchmark. It's still a few months behind others for cybersecurity. - At pass@3, it found 24/32 CVEs (75.0%). DeepSeek V4.1 Flash 1017 found 28/32 (87.5%) - Single-run recall is 59.4%, vs 70.8% for DeepSeek - Precision is 80.5%, meaning it reports ~40% more false positives than DeepSeek - Cost: $4.20 per CVE found, vs $2.40 for DeepSeek V4.1 Flash 1017 It's honestly not that bad, but compared to the alternatives we have today, I would not recommend using it for cybersecurity tasks. 1/3 🧵
    080259
  11. Aikido✓@AikidoSecurity
    Aikido
    RT @lookatcomputer: Secret leaked!!! 🚨 I spent a day back in April filming with @CultRepo. We cover the story behind Gitleaks and look to the future with Betterleaks. Check it out at 2pm Central Time on YouTube
    020247
  12. Aikido✓@AikidoSecurity
    🔥 Aikido Images that fix the Brotli flaw (CVE-2026-111497) are now available FREE in our public ECR. Node: - node:18 - node:18-bookworm-slim - node:18-bullseye-slim - node:20 - node:20-bullseye-slim - node:20.20.2-bookworm-slim - node:20.20.2-trixie - node:20.20.2-trixie-slim Ubuntu: - ubuntu:20.04-brotli - ubuntu:22.04-brotli - ubuntu:24.04-brotli - ubuntu:25.04-brotli Pull a patched image and stay on your current version.
    Download
    310283.5K
  13. Aikido✓@AikidoSecurity
    Posts @AikidoSecurity
    Aikido @AikidoSecurity
    Evolving threat 🚨 CVE-2026-111497, previously known to affect Node.js (node2shell) and Python has evolved into “HTTP2Shell.” A significant blast radius. This vulnerability leaves many libraries and applications using HTTP vulnerable to pre-auth RCE via Brotli decompression. Please be aware. Fixes not yet available for all affected services. Look for Brotli (1.2.1) dependency upgrades when they become available.
    004551
  14. Aikido✓@AikidoSecurity
    Posts @AikidoSecurity
    Update on CVE-2026-111497 (Node2Shell / HTTP2Shell / Brotli2Shell): Fixes are now out for Node.js, Bun, Envoy, Istio, .NET, Python, Java brotli4j and libbrotli, plus Debian, Alpine and Amazon Linux. Still no fix: Ubuntu, SUSE and standard RHEL repos. Fedora and Red Hat are only partly fixed. Patch status by platform: No patch yet? Disable Brotli decoding until there is one.
    007404
  15. Aikido✓@AikidoSecurity
    👀 @madelinelawren is featured in @BusinessInsider's guide to protecting your information from the PHP flaw. Even if you don't build software, she says, a lot of your life depends on companies that depend on those systems, and "they could be deeply, deeply vulnerable." ->
    Download
    22242.1K
  16. Aikido✓@AikidoSecurity
    Posts @AikidoSecurity
    The internet is now calling this....Broccoli2Shell
    Aikido @AikidoSecurity
    after this week we will never use the words 2shell again
    1031.6K
  17. Aikido✓@AikidoSecurity
    after this week we will never use the words 2shell again
    191017720.8K
  18. Aikido✓@AikidoSecurity
    Posts @AikidoSecurity
    Updated information on the node2shell -> python2shell -> https2shell development: @openai has since shared they discovered this vulnerability in Feb. While the root cause issue was fixed in Brotli source code then, it wasn’t known that it gave rise to a security vulnerability.
    131411.5K
  19. Aikido✓@AikidoSecurity
    Posts @AikidoSecurity
    Bun @bunjavascript
    We published three security advisories for Bun 1.4.3 and earlier: compromised eMudhra certificates, the brotli decoder bug (HTTP2Shell), and the HTTP/3 "Header Accordions" attack. These are all fixed in Bun 1.4.4. Please upgrade, and rebuild anything made with `bun build --compile` $ bun upgrade
    00214.7K
  20. Bun@bunjavascript
    We published three security advisories for Bun 1.4.3 and earlier: compromised eMudhra certificates, the brotli decoder bug (HTTP2Shell), and the HTTP/3 "Header Accordions" attack. These are all fixed in Bun 1.4.4. Please upgrade, and rebuild anything made with `bun build --compile` $ bun upgrade
    194760540.3K
  21. Show more posts