Posts with #HTTP3

#HTTP3

Public posts on X that use #HTTP3.

Related hashtags

  1. Robin Marx@programmingart
    #HTTP3 and #QUIC promise some potentially powerful performance improvements for HTTP-based APIs (say REST and GraphQL). Learn how Head-of-Line blocking, prioritization, 0-RTT and server push impact this specific use case in my interview with @dret:
    01457
  2. Robin Marx@programmingart
    Had a fun chat with the great @davidbombal today, talking about all things #QUIC and #HTTP3! Expect an interesting video on YouTube sometime in the coming weeks! In preparation, look at some discussions he had with @packetpioneer on all things Wireshark:
    Download
    21048
  3. Robin Marx@programmingart
    The huge #HTTP3 Time-To-First-Byte improvements (compared to HTTP/2) shared earlier by @wix turned out to be overly optimistic and skewed by including DNS lookups in the metric. These updated results are more what I would expect, but still very impactful for > 200ms RTT conns.
    Alon Kochba @alonkochba
    8. A fairer comparison between h2 and h3 would be of the time between connectStart and responseStart: Connection + SSL handshake + request to first byte of response Attached are the p75 and p90 gains for this metric, which are more inline with the expected gains considering RTT
    11136
  4. Alon Kochba@alonkochba
    @alonkochba
    8. A fairer comparison between h2 and h3 would be of the time between connectStart and responseStart: Connection + SSL handshake + request to first byte of response Attached are the p75 and p90 gains for this metric, which are more inline with the expected gains considering RTT
    Download
    0413
  5. Robin Marx@programmingart
    I've started working on a #QUIC and #HTTP3 talk that focuses on challenges for network operators. Detecting and tracking QUIC connections, DDoS protection, Load Balancing, and more! This will first be offered as a paid training for companies, later made public on YouTube.
    Download
    21769
  6. Robin Marx@programmingart
    #QUIC and #HTTP3 are very secure, but that can also make them hard to deploy. Find out more about how this impacts firewalls, load balancers, wireshark, TLS intercepters, DDoS prevention and local (IoT) networks in my recent @OWASP talk:
    22277
  7. Robin Marx@programmingart
    Today, after over 5 years of work, HTTP/3 was finally standardized as RFC 9114! Together with RFC 9204 (QPACK header compression) and RFC 9218 (Extensible Priorities) it ushers in an important new chapter for the Web! Proud to have been part of this!
    Download
    291.4K4.2K
  8. Robin Marx@programmingart
    @programmingart
    HTTP/2 was also updated as the new RFC 9113 mainly to remove the old prioritization system. Even HTTP/1.1 and general HTTP semantics + caching concepts were tightened up in RFCs 9110-9112. Big day for the arguably most used application layer protocol 😃
    Download
    8233776
  9. Robin Marx@programmingart
    @programmingart
    In case you want to know more about why #HTTP3 is needed and how it works, I have an in-depth article series @smashingmag :
    11153524
  10. Robin Marx@programmingart
    For a new blogpost, I'm trying to create the Ultimate #HTTP3 vs #HTTP2 protocol stack image to Rule Them All™. Would love to get some feedback on clarity/missing aspects and (God forbid) correctness.
    Download
    17234824
  11. Robin Marx@programmingart
    Part 3/3 of my series "HTTP/3 from A to Z" is now online. In it, I look at #HTTP3 and #QUIC's practical deployment and testing challenges. All you need to know about page adaptations, clients, servers, alt-svc and tooling support via @smashingmag:
    Download
    562185
  12. Robin Marx@programmingart
    Even today, it can be challenging to test basic #HTTP3 and #QUIC support. As such, I've created an up-to-date docker image of cURL with full H3 support for no-nonsense testing: Includes qlog and alt-svc support! Grab it while it's hot!
    Download
    31496
  13. Igor Os✓@igor_os777
    In light of the #HTTP3-related (and still unpatched) bug in #Firefox: open about:preferences#privacy and uncheck everything in the Firefox Data Collection and Use section. Also set "network.http.http3.enabled" to "false".
    Download
    244
  14. Robin Marx@programmingart
    Today @fastly published a nice blog post about how they are supporting our qlog debugging format for their H2O #QUIC and #HTTP3 server. QUIC comes with unique challenges that qlog and qvis help to tackle. @Cloudflare also uses our tools for this.
    01668
  15. Robin Marx@programmingart
    My @smashingconf talk "Married to HTTP/3" is now online at It's an approachable introduction to the protocol and includes many practical tips for developers to start using and testing #HTTP3 #webperf It also has pictures of babies and flaming swords 😏
    Download
    11556
  16. Robin Marx@programmingart
    Mozilla has now published an interesting postmortem on the #HTTP3 related Firefox problems a few weeks ago: Upper vs lowercase HTTP headers, a gift that keeps on giving. Also "single socket thread for all requests" sounds like an... interesting choice.
    2523
  17. Oracle Open Source✓@OracleOSS
    💡 Java 26 is comming soon! JDK 26 upgrades HttpClient — opt-in HTTP/3 (QUIC), smarter timeouts, file-channel uploads, stronger TLS controls, and RFC-aligned headers/cookies. Read: #Java #JDK26 #HTTP3 #OpenJDK
    Download
    1251376.7K
  18. Robin Marx@programmingart
    Very happy to report that *both* our papers on #QUIC and #HTTP3 debugging with qlog and qvis have been accepted for publication! One for the @ACMSIGCOMM EPIQ workshop, the other for @inretafo's ANRW! Preprints and open source code available at
    Download
    41356
  19. Show more posts